Customer Portal

The Interpreter Intelligence Customer Portal provides an Interface for Agency
Customers/Requestors to place requests for new Bookings online, view the bookings
Calendar, check Interpreter Assignments, view Invoices, Reports and Verification of
Service documents for jobs according to the permissions granted. To setup Customer Portal
Access for your Requestors please see the topic ‘Creating a Requestor’.

This document can be sent to Customers/Requestors as a training resource.

Customer Portal for Requestors

The URL, username and password to access the Customer Portal will be provided by your
agency who also manages your account. You will likely be asked to change your password
when you first login to the Customer Portal.

Please note that some options described herein may not be enabled by your agency. Please
contact your agency if you have questions about access to any of the features outlined.

Dashboard

When you first login to the Customer Portal you will automatically land on the Dashboard. This
can also be accessed at any time by selecting the ‘Home’ menu and clicking on ‘Dashboard’.

Most of the functions that you will need are available directly from the Dashboard:

e Get a bird’s eye view of the Bookings/Jobs Calendar for your company for a month,
week, or day at a time. Bookings are color-coded by Status, the color legend can be
found at the top left of the calendar. You can use the arrow toggles » to jump
backwards or forwards on the Calendar or you can use the Calendar icon to select a
specific date.

e Depending on your Customer Associations in Il, you can use the Clients & Locations
drop down menus to further refine your view of Bookings.

e Hover over any Bookings in the Calendar to get a pop-up with more details such as
Created By, Language, Start/End Date/Time etc.

e Click on any Booking to see a menu of actions that can be taken such as Edit, Close
etc.

e Click on Daily Bookings Log to print or save a day’s log of bookings for a given date.
Use it as a sign-in sheet for interpreters or a reference point for your front desk staff.



e Search for a specific Booking by its reference number in the Job # search box at the
top of the page.

e If your agency posted a message for you, you'll see it right at the top of the Dashboard
under Messages and Alerts or they can create a Splash Message right above that for
any Important reminders or process changes.

e Click the blue Create New Booking button to enter a new Booking request, alternatively
access the ‘Home’ menu and click on ‘Create New’.
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e Use the Tabular View button to see a list of all Bookings in a grid format, this will give
you at-a-glance detail of all bookings. You can filter the data by typing into the column
headers (or selecting a drop down value where available) and if you wish to see
more/less Booking details you can use the Reset Columns button to add/remove
columns. Use the drop down arrow next to any Booking to access the actions menu.

e You can also access a tabular view of all Bookings at any time using the ‘Home’ menu
and selecting ‘Manage Bookings’
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Create New Booking

Click the blue Create New Booking button to enter a new Booking request, alternatively
access the ‘Home’ menu and click on ‘Create New’.

Any fields marked with a red asterisk % must be populated, you can hover over the
question mark icon ? at any time to get help text on the appropriate field

Start with the Client at the top, fill in the value and hit Tab to move to the next field.

Requestor Information

The Customer and Bill To fields will be automatically populated for you
The Location may also be populated for you, otherwise select a Client from the
drop down list or or start typing and select from the lookup

o The Requested by and Notification Email fields will also be populated based
on your (Requestor) profile

Service Location

o The Location field may be automatically populated for you, otherwise select a
value from the drop down list

o The Special Instructions box may have information as added by your Agency
and this cannot be modified

Appointment Details

Select the required Language

Select the Service Type e.g. Face to Face, Video (Scheduled) etc.

Enter the # Interpreters Requested (this will default to 1)

Select the Consumer - this is the person receiving the service

You may need to select Additional References and Additional Requirements
depending on how your Agency has set up the booking form

o You can add notes to the Appointment Details box

o O O O O

Calendar

o Select the Expected Start Date using the calendar pop up

o Enter the Expected Start Time

o Select the Duration Hours and Minutes, note that you must select both even if
one of the values is zero

Notes

o You can add any additional notes as required by your Agency in the Job Details
box
Finally click the blue Save button at the bottom of the page



e Note that any fields that have a pencil/edit icon will allow you to either edit an existing
record (by selecting it first) or creating a new record, however, it is recommended that
you check with your Agency before adding/modifying records.
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e And that’s it, you’re done! The Booking will now be available to your Agency for review
and Assignment

Create Follow-up Bookings

The Follow-up Appointment function is useful when you wish to create a single follow-up job for
the same Client, Consumer, Language etc. i.e. if all parameters on the job are the same as
the original with the exception of the scheduled time for the appointment. Everything

above the Calendar section of the original job will be copied to the Follow-up Appointment/Job.

You can access the Follow-up Booking function in a number of ways:

e From the Dashboard find the original Booking from which the Follow-up will be
created (either in Calendar or Tabular View), click on the Booking/drop down menu
beside the Booking and select ‘Create Follow-up’ or

e From within the original Booking (after it has been saved or choosing Edit on the job
action menu) click on the green More button on the left hand navigation pane and select
‘Create Follow-up’

e When the Follow-up Booking has been created, simply complete the Booking by
selecting the Expected Start Date, entering the Expected Start Time, the Duration
Hours and Minutes, and optionally any Job Details notes that pertain to this Booking.
Finally click the blue Save button at the bottom of the page
By selecting the Recurring tab within the original Booking or the Follow-up Booking you
can see that the bookings are related as both will be listed

e Also note that related Jobs will have the same Booking # but unique Job #.

Create Recurring Bookings

The Recurring function is useful when you wish to create multiple and regularly scheduled
follow-up jobs for the same Client, Consumer, Language etc. As with Follow-up
Bookings, everything above the Calendar section will be copied to the Recurring Job(s). The



difference between a Follow-up and Recurring Bookings is that recurring jobs follow a set
schedule such as daily, weekly or monthly, and you can create more than one of these in a
single action.

You can access the Recurring Booking function in a number of ways:

e From the Dashboard find the original Booking which will be made recurring (either in
Calendar or Tabular View), click on the Booking/drop down menu beside the Booking
and select ‘Make Recurring’ or

e From within the original Booking (after it has been saved or choosing Edit on the job
action menu) click on the green More button on the left hand navigation pane and select
‘Make Recurring’

e You will receive a Repeat Job dialog box which will allow you to:

o choose the recurring schedule - Daily/Weekly/Monthly
o the day of the week of the recurrence as relevant
o the date in the Recurrence starts on: field is the date of the original job
therefore you should not change this unless you wish to reschedule the original
job
o number of occurrences (in addition to the original Booking) or the end date for
the recurrence
click the Make Recurring button.
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e By selecting the Recurring tab within any of these Bookings you can see that the
bookings are related as all of the jobs will be listed
e Also note that related Jobs will have the same Booking # but unique Job #.

Create Duplicate Bookings

The Duplicate function is useful when you wish to create a single job where many but not all
of the parameters are the same as the original job. As with Follow-up Appointments,
everything above the Calendar section will be copied to the Duplicate booking. The main
difference between a Follow-up Appointment and a Duplicate job is that a duplicate, once
created, will no longer be related to the original job, i.e. there will be no other jobs in the
Recurring tab of the duplicated job and it will not share a Booking # with the original Booking.
Therefore you can change any information on the Duplicate booking without affecting the
original booking while saving time on data entry.



You can access the Duplicate Booking function in a number of ways:

e From the Dashboard find the original Booking which you will Duplicate (either in
Calendar or Tabular View), click on the Booking/drop down menu beside the Booking
and select ‘Duplicate’ or

e From within the original Booking (after it has been saved or choosing Edit on the job
action menu) click on the green More button on the left hand navigation pane and select
‘Duplicate’

You can then Edit any of the parameters on the Booking as required
Finally click the blue Save button at the bottom of the page

Monitoring & Updating Bookings

You can View a Booking at any time to monitor its status, for example a Booking has changed
from Open to Assigned; use the Calendar or Tabular View on the Dashboard or use the job
actions menu to see more. You can navigate to the Assignments tab to see the Interpreter
that has been assigned. Note that as a Requestor you will also receive email notifications from
the Agency if there are any changes to the job and as the job moves through the Workflow.

To make a change to a Booking you can click on the Booking and select Edit (note that your
Agency may disable edits within a certain timeframe of the Expected Start Date/Time). Make
any changes as required and remember to Save the Booking.

Note that for Related Bookings (Recurring and Follow-up), any changes made to the
Booking above the Calendar section will persist across all related Bookings. Any changes
made to the Calendar section or below will prompt you as to how the changes should apply
within the related set such as to all bookings, all future bookings etc.

Closing & Cancelling Bookings

If enabled by your Agency you can Close or Cancel Bookings when the appointment is
complete or the appointment is no longer required for example. Note that some agencies will
require Interpreters to Close/Cancel jobs.

To Close a Booking

From Calendar View click on a Booking to access the actions menu, or

In Tabular View use the drop down menu next to the Booking, or

Within the Booking use the green More button

Select Close

Modify the Start/End times as appropriate

Click on the Browse button to upload the VoS

Click on Add Incidental to add Mileage, Parking etc. repeat this process for individual
Incidentals



e Click the Next button and you will receive a Close success message
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e |If an Interpreter has Closed the Booking and you wish to view the VoS, you can
access this and any other documents attached to the Booking on the Documents tab in
the top right section of the Booking.

To Cancel a Booking

Note that as with Booking updates, your Agency may disable Cancellations within a certain
timeframe of the Expected Start Date/Time
e From Calendar View click on a Booking to access the actions menu, or
In Tabular View use the drop down menu next to the Booking, or
Within the Booking use the green More button
Select Cancel
Choose a Cancellation Reason from the drop down menu
Enter any additional information relevant to the Cancellation
Click the Cancel Booking button and you will receive a success message



Cancel Booking

Please select the reason for the cancellation in this field: ~ @&
[Choose a Cancellation Reason] v o

Please enter any additional information for the cancellation in this field:
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Reports (if enabled by your Agency)

Interpreter Intelligence has a number of reports that provide insight into the data related to your
appointments. These reports will give you more visibility into your Booking statistics overall as
well as by Location and Language.

To access Reports (if this has been enabled for you by your Agency), go to the ‘Reports’ menu
and select ‘Overview’.

You can specify the Period Starting and Period Ending to include in the Reports, such as a
Daily, Weekly or Monthly View. The data on the Jobs tab is presented graphically, while the
Hours and Statistics tabs will display Tabular data as well as some additional data such as
Cancellation & Unfulfilled Reasons. The References tab will give you data on the Additional
References that are collected within Bookings if enabled.

You can Export the raw data from any individual Report as well as using the Export options
under the Re-run Reports button.
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Financials (if enabled by your Agency)

The Financial menu will allow you to view Invoices generated for you by your Agency. The
summary page will display a high level view of all available Invoices. You can hover over the
status icon (St.) to get a quick view of the status of any individual Invoice and you can filter this
table by Invoice Status and any of the other columns available.

The View commands found under the action menu for a particular Invoice will allow you to view
the Invoice in detail as well as Print or Save a pdf document of the actual Invoice. You can
also Export a Customer Summary Report.

For further information on the Customer Portal please also view the
Interpreter Intelligence Customer Portal Overview video



https://www.youtube.com/watch?v=Kouh9jApkrQ&list=PLmp4xe_peVmz_0KZhFbZnKCDLX4hxHLZE&index=1

